• Willkommen im Forum von XenFiles!
    Wenn Du ein registriertes Mitglied bist, logge Dich bitte ein oder klicke auf Registrieren, wenn Du kein Mitglied bist.
    Nur als registriertes Mitglied kannst Du alle Funktionen des Forums nutzen.
    Die Registration ist völlig kostenlos!
    Registrieren Anmelden

Font Awesome Icon für Editor wird nicht erkannt

Ragnarok

Fortgeschrittener
Mitglied
Hi,

ich möchte ein Font Awesome Icon für einen selbst erstellten BB-Code nutzen. Wenn ich im ACP auf diesen Punkt gehe und "youtube" für das YouTube-Icon in das Feld eingebe, passiert nichts. Das Feld bleibt einfach leer. Man kann zwar draufklicken, aber es wird kein Icon angezeigt.

Bildschirmfoto 2019-04-24 um 22.18.05.pngBildschirmfoto 2019-04-24 um 22.19.22.png

Jemand eine Idee, woran das liegen könnte?
 

Terror

Foren Guru
Elite Mitglied
guck doch einfach nach, wie das bei den anderen buttons gemacht wurde. geht viel schneller als immer erst fragen ;)

bbcode.png
 
T S

Ragnarok

Fortgeschrittener
Mitglied
Zuletzt bearbeitet:

Naapi

Team Mitglied
Administrator
Das kann auch am Style liegen. Mit unserem Style hier gab es auch ein Problem, dass ein Awesome Icon nicht angezeigt wurde. Im XenForo Standard Style aber schon.

Keine Sorge, das habe ich schon. Sonst würde ich nicht fragen.
Davon hast du aber im Startthema nichts geschrieben! Bitte etwas höflicher wenn man dir schon helfen möchte.
 
T S

Ragnarok

Fortgeschrittener
Mitglied
Das war aber nicht böse gemeint. Sorry, falls es den Anschein erweckt hat. Ich entschuldige mich hiermit auch nochmal bei dir, @Terror

Das kann auch am Style liegen. Mit unserem Style hier gab es auch ein Problem, dass ein Awesome Icon nicht angezeigt wurde. Im XenForo Standard Style aber schon.
Dachte ich mir auch, weil in den UI.X Styles ja so manche Dinge nicht funktionieren. Aber komischerweise wird auch beim Standard-Style nichts angezeigt. Selbst im ACP sieht man beim Editor keinen Button.
 

d0c

Foren Guru
Elite Mitglied
Komplett die Klasse ausschreiben und zwar so: fas fa-helicopter (wird als BBCODE Icon angezeigt)

In deinem Falle: fab fa-youtube

Sollte funktionieren, dennoch wird gerade das Youtube Icon nicht angezeigt, warum auch immer. Viele andere Icons werden dargestellt.
 

d0c

Foren Guru
Elite Mitglied
fas und fab dadurch wird einfach nur der icon style definiert und zwar solid oder brand. Ich weiß echt nicht woran es liegt aber es nervt manchmal sehr. Ich habe gerade dasselbe Problem mit einem bestimmten fab Icon, welches nicht angezeigt wird...gerade solche Kleinigkeiten sind nervig weil ich z.b an sowas hängen bleibe und es unbedingt erledigen will und zwar sofort.
 
T S

Ragnarok

Fortgeschrittener
Mitglied
Hat leider auch nicht funktioniert... Aber ich habe jetzt einfach das YouTube-Icon als png hochgeladen. Vielen Dank an alle, die geholfen haben. :)
 

HwlHwl

Fortgeschrittener
Mitglied
Guten Morgen,

gibt es hierzu noch ein paar mehr Informationen., denn auch ich habe das Problem, dass ich z.B. keine Icons sehe.

Welche Version von Font Awesome ist eigentlich bei XF2.1 mit dabei?
Wenn ich mich nicht vollkommen irre ist in der Version XF2.1 die Pro Version von Font Awesome enthalten.
 

HwlHwl

Fortgeschrittener
Mitglied
Okay, wenn ich es richtig sehe habe ich meinen Fehler gefunden, denn wenn ich den folgenden Eintrag
CSS:
font-family: FontAwesome;
z.B. in der extra.less Datei wie folgt abaendere
CSS:
font-family: 'Font Awesome 5 Pro';
dann funktioniert es. Was leider immer noch nicht geht ist das Youtube Symbol, wenn ich dieses ueber den Hexcode versuche einzubinden. Binde ich dieses aber z.B. direkt wie folgt in ein Template ein, funktioniert es:
HTML:
<li>
    <a href="#top" class="button--scroll" data-xf-click="scroll-to">
    <xf:fa icon="fab fa-youtube"/>
    </a>
</li>
Gibt es eigentlich eine andere Moeglichkeit in der CSS (LESS) Datei statt dem Hexcode auch den Namen zu nutzen?
CSS:
.p-navEl a[data-nav-id="home"]::before{content: "\f015";}
Noch eine dumme Frage:
Hier gibt es noch ein Youtube Symbol https://fontawesomeicons.com/youtube ist dies etwas altes? Oder wo kommt dies nun aufeinmal her?
 
T S

Ragnarok

Fortgeschrittener
Mitglied
Guten Morgen,

gibt es hierzu noch ein paar mehr Informationen., denn auch ich habe das Problem, dass ich z.B. keine Icons sehe.

Welche Version von Font Awesome ist eigentlich bei XF2.1 mit dabei?
Wenn ich mich nicht vollkommen irre ist in der Version XF2.1 die Pro Version von Font Awesome enthalten.
Hi,
ich habe leider keine andere Lösung gefunden. Ich habe einfach das Youtube-Symbol als PNG-Datei hochgeladen und das dann als Icon benutzt.
Hier gibt es noch ein Youtube Symbol https://fontawesomeicons.com/youtube ist dies etwas altes? Oder wo kommt dies nun aufeinmal her?
Sieht nach der alten Version aus.
 
Top